kmail: strange behaviour with some s/mime encrypted emails

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

kmail: strange behaviour with some s/mime encrypted emails

Andreas Petzold-2
Hi,

in kmail I routinely sign my emails using s/mime. I rarely use s/mime
encryption, but I haven't seen a problem for a long time. However,
recently a friend of mine sent me two encrypted emails. The first one
from kmail. No problems at all with that email.

The second one he sent from thunderbird and this email is shown as
garbled junk in the message preview pane as you can see here:

http://tinyurl.com/2jq4z6n

Only when I accidentally hit the Enter key the message was decrypted
and readable see

http://tinyurl.com/38fx3e

I asked a number of people to send me s/mime encrypted emails from thunderbird
and the result is always the same.

I had a closer look at the emails to try to find a difference. I found
a couple of small differences, but since I don't know (yet) what a
standard compliant s/mime encrypted email should look like, I don't
know which one is the reason of the problem:

* Attachments:
       - from thunderbird: kmail shows an attachment named "opaque signed data"
       - from kmail: kmail shows no attachment

* Header info:
       - from thunderbird:

Content-Type: application/x-pkcs7-mime;
      name="smime.p7m"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7m"
Content-Description: S/MIME Encrypted Message

       - from kmail:

Content-Type: application/pkcs7-mime;
      smime-type=enveloped-data;
      name="smime.p7m"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7m"

Can one of the experts make sense of this?

Cheers,

Andreas





_______________________________________________
Gpa-dev mailing list
[hidden email]
http://lists.gnupg.org/mailman/listinfo/gpa-dev
Reply | Threaded
Open this post in threaded view
|

Re: kmail: strange behaviour with some s/mime encrypted emails

Bernhard Reiter-7
On Wednesday 30 January 2008 10:09, Andreas Petzold wrote:
> * Header info:
>        - from thunderbird:
>
> Content-Type: application/x-pkcs7-mime;
>       name="smime.p7m"
> Content-Transfer-Encoding: base64
> Content-Disposition: attachment; filename="smime.p7m"
> Content-Description: S/MIME Encrypted Message

Sounds like one of the symptoms of
https://intevation.de/roundup/kolab/issue2182

Which version are you using precisely?
I suggest to try a recent enterprise35 version and file a report
in the tracker above, if this still does not work.

BTW: Your first tinyurl did not work for me.

--
Managing Director - Owner: www.intevation.net       (Free Software Company)
Germany Coordinator: fsfeurope.org. Coordinator: www.Kolab-Konsortium.com.
Intevation GmbH, Osnabrück, DE; Amtsgericht Osnabrück, HRB 18998
Geschäftsführer Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner

_______________________________________________
Gpa-dev mailing list
[hidden email]
http://lists.gnupg.org/mailman/listinfo/gpa-dev

smime.p7s (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: kmail: strange behaviour with some s/mime encrypted emails

Andreas Petzold-2
In reply to this post by Andreas Petzold-2
Hi Bernhard,

Quoting Bernhard Reiter <[hidden email]>:

> On Wednesday 30 January 2008 10:09, Andreas Petzold wrote:
>> * Header info:
>>        - from thunderbird:
>>
>> Content-Type: application/x-pkcs7-mime;
>>       name="smime.p7m"
>> Content-Transfer-Encoding: base64
>> Content-Disposition: attachment; filename="smime.p7m"
>> Content-Description: S/MIME Encrypted Message
>
> Sounds like one of the symptoms of
> https://intevation.de/roundup/kolab/issue2182
>
> Which version are you using precisely?

enterprise 20071204 r744693 packaged by kde-redhat.

> I suggest to try a recent enterprise35 version and file a report
> in the tracker above, if this still does not work.

OK, recently I got an update of my kdepim packages
to version 20080109 r758806. And hooray - no more garbled messages!
But now I can't decrypt them :-( since it says: Unsupported algorithm.
And this is confusing! As you can see from

http://tinyurl.com/38fx3e

my old kmail version was able to decrypt the message.

Is thunderbird doing something non-standard compliant when it omits
the "smime-type=enveloped-data" header or is this a problem in kmail?
Or am I missing something here?

>
> BTW: Your first tinyurl did not work for me.

Sorry, now it should work but

http://tinyurl.com/2jq4z6

Cheers,

Andreas


_______________________________________________
Gpa-dev mailing list
[hidden email]
http://lists.gnupg.org/mailman/listinfo/gpa-dev
Reply | Threaded
Open this post in threaded view
|

Re: kmail: strange behaviour with some s/mime encrypted emails

Andreas Petzold-2
> OK, recently I got an update of my kdepim packages
> to version 20080109 r758806. And hooray - no more garbled messages!
> But now I can't decrypt them :-( since it says: Unsupported algorithm.
> And this is confusing! As you can see from

> http://tinyurl.com/38fx3e

> my old kmail version was able to decrypt the message.

> Is thunderbird doing something non-standard compliant when it omits
> the "smime-type=enveloped-data" header or is this a problem in kmail?
> Or am I missing something here?

Oh my, there seem to be known issues both with thunderbird and kmail:

http://www.nabble.com/forum/ViewPost.jtp?post=10012362&framed=y
https://bugzilla.mozilla.org/show_bug.cgi?id=379625

Still, I don't understand what's really going on. I'd appreciate some  
guidance here.

Cheers,

Andreas


_______________________________________________
Gpa-dev mailing list
[hidden email]
http://lists.gnupg.org/mailman/listinfo/gpa-dev